Page tree
Skip to end of metadata
Go to start of metadata



Introduced in

Version:1.00

Description

Description:Checks the required VBS3 version. If the current VBS3 version is older than the required one, a warning message is shown and false is returned.

Syntax

Syntax:requiredVersion version
Parameters:
  • version: String - Version in the format "Major.Minor" (for example, "1.30").
Return Value:Boolean - Returns true, if required VBS3 version is the same as or newer than the current one; false otherwise.

Examples

Examples:
if !(requiredVersion "1.09") exitWith {};

Additional Information

See also: versionNumber
Multiplayer:
Problems:

Notes







Posted on March 12, 2008
Kronzky
If the script contains a command that was introduced after the required version, it will still generate a syntax error, even if this test is done at the top of the script (as the whole script is parsed before execution).